User stats delayed

Incident Report for Plume

Resolved

This incident has been resolved.
Posted Sep 10, 2026 - 13:51 UTC

Update

User data is back to normal
Posted Sep 10, 2026 - 13:50 UTC

Investigating

We are currently investigating this issue.
Posted Sep 10, 2026 - 11:32 UTC
This incident affected: Website.